rails delete link_to not working after including Jquery UI


This issue can be resolved with rails default way

1) 1st way to resolve

there is application.js file may be at app/assets/javascripts/application.js

add these lines to the file

  //= require jquery
 //= require jquery_ujs

and after that in your application’s layout file add this line

 <%= javascript_include_tag "application" %>

OR

2) 2nd way to resolve

Felix, are you using JQuery? If so, I think the problem could be that you are using JQuery without the updated rails.js file.

Download rails.js here: https://github.com/rails/jquery-ujs/raw/master/src/rails.js Drop it in your javascripts directory, overwriting the rails.js that comes default with rails.

Add a javascript include line to include it.

  <%= javascript_include_tag "rails" %>

Put this after your Jquery include tag. You probably also want to disinclude the javascript defaults if you don’t plan on using prototype.

I included jQuery UI in my application, I found that delete is now working as show, but after doing above Resolved Issue.

 

Advertisements

I am Senior Software Engineer. I love reading, writing, sharing,developing, hiking, movies, trips, mountains, brooks, hills etc.

Posted in JQuery, Ruby Little Codes

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

StackOverFlow
Categories
Archives
%d bloggers like this: